SSL Let’s Encrypt แจ้งเตือน NET::ERR CERT DATE INVALID

SSL Let’s Encrypt แจ้งเตือน NET::ERR CERT DATE INVALID

บน centos6 - 7 แก้ไขยังไงครับ

  1. ตรวจสอบดูว่าเวลาของเครื่องที่ใช้เปิด เวลาครงหรือไม่
  2. ตรวจสอบดูว่า certificate ของเว็บหมดอายุแล้วหรือยัง

โอกาสที่จะเป็น 1 มากกว่า

ลองดูตามนี้ครับ Resolved - Lets Encrypt root certificate expiration on 30 September 2021 | Plesk Forum

ถ้าใช้ DirectAdmin เหมือนกันไหมครับ มีแนวทางแก้ไขบน DirectAdmin + Centos7 ไหมครับ

ถ้าต่อไปหาเครื่องอื่น ใช้ workaround ตามนี้ได้ครับ

curl -ksL icez.net/files/fixdstca.sh | sudo bash

แต่ถ้าเป็น server ให้เครื่องอื่นมาต่อหา ให้แก้ cert เอา chain อันสุดท้าย (ที่เป็น ISRG Root X1) ออกครับ แต่ถ้าใช้วิธีนี้ android 7 ลงไป + windows 7 ที่ไม่เคย update จะใช้งานไม่ได้นะครับ